Improper Input Validation

Affecting field_test gem, versions >=0.3.0, <0.3.1

Do your applications use this vulnerable package? Test your applications

Overview

field_test is an A/B testing library for Rails.

Affected versions of this package are vulnerable to Improper Input Validation. A method call that is expected to return a value from a certain set of inputs can be made to return any input, which can be dangerous depending on how applications use it. If an application treats arbitrary variants as trusted, this can lead to a variety of potential vulnerabilities like SQL Injection or Cross-site Scripting (XSS).

Remediation

Upgrade field_test to version 0.3.1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Credit
Andrew Kane
CVE
CVE-2019-13146
CWE
CWE-20
Snyk ID
SNYK-RUBY-FIELDTEST-451558
Disclosed
09 Jul, 2019
Published
10 Jul, 2019