Improper Authorization

Affecting tuf package, versions [,0.12)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

tuf is a secure updater framework for Python.

Affected versions of this package are vulnerable to Improper Authorization. It will incorrectly trust a previously downloaded root metadata file which failed verification at download time. This allows an attacker who is able to serve multiple new versions of root metadata (i.e. by a person-in-the-middle attack) culminating in a version which has not been correctly signed to control the trust chain for future updates.

Remediation

Upgrade tuf to version 0.12 or higher.

References

CVSS Score

5.7
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    High
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
Credit
Unknown
CVE
CVE-2020-15163
CWE
CWE-285
Snyk ID
SNYK-PYTHON-TUF-610278
Disclosed
10 Sep, 2020
Published
10 Sep, 2020