Security Bypass

Affecting pyjwt package, versions [,1.0.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of pyjwt are vulnerable to Security Bypass.

when alg=none its accept value for the key which could bypass signature verification.

Remediation

Upgrade pyjwt to version 1.0.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Credit
Unknown
CWE
CWE-284
Snyk ID
SNYK-PYTHON-PYJWT-40733
Disclosed
17 Mar, 2015
Published
04 Dec, 2017