SQL Injection

Affecting plone package, versions [0,5.2.2)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Plone is an user friendly and extensible Content Management System running on top of Python and Zope.

Affected versions of this package are vulnerable to SQL Injection in DTML or in connection objects allows users to perform unwanted SQL queries.

Remediation

Upgrade Plone to version 5.2.2 or higher.

References

CVSS Score

5.6
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Michael Brunnbauer and Michael Howitz
CVE
CVE-2020-7939
CWE
CWE-89
Snyk ID
SNYK-PYTHON-PLONE-543305
Disclosed
26 Jan, 2020
Published
27 Jan, 2020