Unprotected Storage of Credentials

Affecting django-nopassword package, versions [,5.0.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

django-nopassword is an authentication backend for django that uses a one time code instead of passwords

Affected versions of this package are vulnerable to Unprotected Storage of Credentials. It stores cleartext secrets in the database.

Remediation

Upgrade django-nopassword to version 5.0.0 or higher.

References

CVSS Score

6.8
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Credit
Unknown
CVE
CVE-2019-10682
CWE
CWE-256
Snyk ID
SNYK-PYTHON-DJANGONOPASSWORD-560576
Disclosed
18 Mar, 2020
Published
18 Mar, 2020