Cross-site Request Forgery (CSRF)

Affecting phpmyadmin/phpmyadmin package, versions >=4.7.0, <4.8.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, etc.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Credit
Daniel Le Gall, Mustafa Hasan, Prasetia Ari
CVE
CVE-2018-19969
CWE
CWE-352
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-72683
Disclosed
11 Dec, 2018
Published
12 Dec, 2018