Cross-site Request Forgery (CSRF)

Affecting phpmyadmin/phpmyadmin package, versions <4.8.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a MySQL web administration tool.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). It allows the attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.0.1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:P/RL:O/RC:R
Credit
Unknown
CVE
CVE-2018-10188
CWE
CWE-351
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-72141
Disclosed
19 Apr, 2018
Published
02 May, 2018