Cross-site Request Forgery (CSRF)

Affecting phpmyadmin/phpmyadmin package, versions <4.9.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim. Only the 'cookie' auth_type is affected; users can temporary use phpMyAdmin's http authentication as a workaround.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.9.0 or higher.

References

CVSS Score

8.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H/E:P/RL:O/RC:R
Credit
Unknown
CVE
CVE-2019-12616
CWE
CWE-352
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-174914
Disclosed
05 Jun, 2019
Published
05 Jun, 2019