Information Exposure

Affecting moodle/moodle package, versions >=3.6, <3.6.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Information Exposure due to improper restrictions to the current users' conversations in a web service used to fetch messages.

Remediation

Upgrade moodle/moodle to version 3.6.4 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/RL:O
Credit
Mazen Gamal
CVE
CVE-2019-10154
CWE
CWE-200
Snyk ID
SNYK-PHP-MOODLEMOODLE-451047
Disclosed
26 Jun, 2019
Published
26 Jun, 2019