Information Exposure

Affecting moodle/moodle package, versions >=3.4.0, <3.4.8 || >=3.5.0, <3.5.5 || >=3.6.0, <3.6.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Information Exposure. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events.

Remediation

Upgrade moodle/moodle to version 3.4.8, 3.5.5, 3.6.3 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Juan Leyva
CVE
CVE-2019-3848
CWE
CWE-200
Snyk ID
SNYK-PHP-MOODLEMOODLE-174007
Disclosed
26 Mar, 2019
Published
26 Mar, 2019