Improper Authentication

Affecting moodle/moodle package, versions >=3.5, <3.5.8 || >=3.6, <3.6.6 || >=3.7, <3.7.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Improper Authentication. Activity creation capabilities were not correctly respected when selecting the activity to use for a course in single activity mode.

Remediation

Upgrade moodle/moodle to version 3.5.8, 3.6.6, 3.7.2 or higher.

References

CVSS Score

3.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Credit
Andrew Nicols
CVE
CVE-2019-14829
CWE
CWE-287
Snyk ID
SNYK-PHP-MOODLEMOODLE-1088015
Disclosed
21 Mar, 2021
Published
21 Mar, 2021