Privilege Escalation

Affecting moodle/moodle package, versions >=3.9.0, <3.9.1 || >=3.8.0, <3.8.4 || >=3.7.0, <3.7.7 || <3.5.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Privilege Escalation. Users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager.

Remediation

Upgrade moodle/moodle to version 3.9.1, 3.8.4, 3.7.7, 3.5.13 or higher.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Credit
Unknown
CVE
CVE-2020-25629
CWE
CWE-264
Snyk ID
SNYK-PHP-MOODLEMOODLE-1048845
Disclosed
08 Dec, 2020
Published
08 Dec, 2020