Sensitive Data Exposure

Affecting moodle/moodle package, versions >=3.7.0, <3.7.9 || >=3.8.0, <3.8.6 || >=3.9.0, <3.9.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Sensitive Data Exposure. The participants table download in Moodle always included user emails, but should have only done so when users' emails are not hidden.

Remediation

Upgrade moodle/moodle to version 3.7.9, 3.8.6, 3.9.3 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
A. Schenkel
CVE
CVE-2020-25703
CWE
CWE-201
Snyk ID
SNYK-PHP-MOODLEMOODLE-1042271
Disclosed
20 Nov, 2020
Published
20 Nov, 2020