Improper Access Control

Affecting mediawiki/core package, versions >=1.27.0, <1.27.6 || >=1.30.0, <1.30.2 || >=1.31.0, <1.31.2 || >=1.32.0, <1.32.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mediawiki/core is a Free software wiki application developed by the Wikimedia Foundation and others.

Note: This package is not maintained on Packagist anymore, but newer releases exist.

Affected versions of this package are vulnerable to Improper Access Control. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API.

Remediation

Upgrade mediawiki/core to version 1.27.6, 1.30.2, 1.31.2, 1.32.2 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2019-12472
CWE
CWE-284
Snyk ID
SNYK-PHP-MEDIAWIKICORE-1041749
Disclosed
19 Nov, 2020
Published
19 Nov, 2020