Security Bypass (PHP script injection)

Affecting magento/community-edition package, versions >=2.1.0, <2.1.18 || >=2.2.0, <2.2.9 || >=2.3.0, <2.3.2

Do your applications use this vulnerable package? Test your applications

Overview

magento/community-edition is a modern cloud eCommerce platform.

Affected versions of this package are vulnerable to Security Bypass (PHP script injection). An authenticated user can bypass security protections that prevent arbitrary PHP script upload via form data injection.

Remediation

Upgrade magento/community-edition to version 2.1.18, 2.2.9, 2.3.2 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Max Chadwick
CVE
CVE-2019-7871
CWE
CWE-358
Snyk ID
SNYK-PHP-MAGENTOCOMMUNITYEDITION-459035
Disclosed
02 Aug, 2019
Published
12 Aug, 2019