Inadequate Encryption Strength

Affecting magento/community-edition package, versions >=2.1.0, <2.1.18 || >=2.2.0, <2.2.9 || >=2.3.0, <2.3.2

Do your applications use this vulnerable package? Test your applications

Overview

magento/community-edition is a modern cloud eCommerce platform.

Affected versions of this package are vulnerable to Inadequate Encryption Strength. A cryptographically weak pseudo-rando number generator is used in multiple security relevant contexts.

Remediation

Upgrade magento/community-edition to version 2.1.18, 2.2.9, 2.3.2 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Magento
CVE
CVE-2019-7860
CWE
CWE-326
Snyk ID
SNYK-PHP-MAGENTOCOMMUNITYEDITION-459005
Disclosed
02 Aug, 2019
Published
12 Aug, 2019