Information Exposure

Affecting librenms/librenms package, versions <1.50.1

Do your applications use this vulnerable package? Test your applications

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to Information Exposure. An attacker can fingerprint the exact code version installed and disclose local file paths.

Remediation

Upgrade librenms/librenms to version 1.50.1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CVE
CVE-2019-10667
CWE
CWE-200
Snyk ID
SNYK-PHP-LIBRENMSLIBRENMS-536059
Disclosed
11 Oct, 2019
Published
26 Nov, 2019