Improper Validation

Affecting ezsystems/ezplatform package, versions >=1.13.0, <1.13.5.1 || >=2.5.0, <2.5.4 || >=1.7.0, <1.7.9.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ezsystems/ezplatform is a fully open source professional CMS (Content Management System) developed by eZ Systems and the eZ Community.

Affected versions of this package are vulnerable to Improper Validation. Front-controller scripts such as app.php should not be cached due to sensitive data being contained within. Note: This vulnerability doesn't affect eZ Platform Cloud (running eZ Platform on the Platform.sh cloud service), or usage of the .platform.app.yaml configuration file.

Remediation

Upgrade ezsystems/ezplatform to version 1.13.5.1, 2.5.4, 1.7.9.1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C
Credit
Unknown
CWE
CWE-295
Snyk ID
SNYK-PHP-EZSYSTEMSEZPLATFORM-546873
Disclosed
06 Feb, 2020
Published
06 Feb, 2020