Arbitrary Code Execution

Affecting doctrine/orm package, versions <2.4.8 || >=2.5.0, <2.5.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of doctrine/orm are vulnerable to Arbitrary Code Execution.

Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.

Remediation

Upgrade doctrine/orm to version 2.5.1, 2.4.8 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Ryan Lane
CVE
CVE-2015-5723
CWE
CWE-94
Snyk ID
SNYK-PHP-DOCTRINEORM-70031
Disclosed
31 Aug, 2015
Published
31 Aug, 2015