Cross-site Request Forgery (CSRF)

Affecting contao/core-bundle package, versions >=4.7.0, <4.7.3

Do your applications use this vulnerable package? Test your applications

Overview

contao/core-bundle is an Open Source PHP Content Management System for people who want a professional website that is easy to maintain. Visit the project website for more information.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) as the CSRF token check can be bypassed.

Remediation

Upgrade contao/core-bundle to version 4.7.3 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/RL:O
Credit
Ali Razzaq
CVE
CVE-2019-10642
CWE
CWE-352
Snyk ID
SNYK-PHP-CONTAOCOREBUNDLE-174168
Disclosed
09 Apr, 2019
Published
15 Apr, 2019