Arbitrary Code Execution

Affecting @thi.ng/egf package, versions <0.4.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

@thi.ng/egf is an Extensible Graph Format

Affected versions of this package are vulnerable to Arbitrary Code Execution via gpg-tagged property values (only if decrypt: true option is enabled). By default the EGF parse functions do not attempt to decrypt values (since GPG is only available in a non-browser env).

Remediation

Upgrade @thi.ng/egf to version 0.4.0 or higher.

References

CVSS Score

6.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2021-21412
CWE
CWE-78
Snyk ID
SNYK-JS-THINGEGF-1089810
Disclosed
31 Mar, 2021
Published
31 Mar, 2021