Improper Input Validation

Affecting script-manager package, versions >=0.8.6 <0.9.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

script-manager is a manager for running foreign and potentially dangerous scripts in the cluster.

Affected versions of this package are vulnerable to Improper Input Validation. It allows loading arbitary non-production code (js files) via an unintended require.

Remediation

Upgrade script-manager to version 0.9.0 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P/RL:O/RC:C
Credit
ermilov
CWE
CWE-20
Snyk ID
SNYK-JS-SCRIPTMANAGER-548308
Disclosed
26 Jul, 2019
Published
07 Feb, 2020