Malicious Package

Affecting oauth-validator package, versions =1.0.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

oauth-validator is a library for validating WeChat, QQ, Weibo user identities.

This package contained malicious code that would enumerate password, CVC, Card Number fields from forms and send the extracted values to a remote server.

Remediation

Avoid using version 1.0.2 of oauth-validator.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
npm security
CWE
CWE-506
Snyk ID
SNYK-JS-OAUTHVALIDATOR-450982
Disclosed
15 May, 2018
Published
26 Jun, 2019