Prototype Pollution

Affecting node.extend package, versions <1.1.7 || >=2.0.0 <2.0.1

Overview

node.extend is a port of jQuery.extend that actually works on node.js.

Affected versions of this package are vulnerable to Prototype Pollution. An attacker could inject arbitrary properties onto Object.prototype.

Remediation

Upgrade node.extend to version 1.1.7, 2.0.1 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

1.8
low severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    High
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:L/E:F/RL:O/RC:C
Credit
asgerf
CVE
CVE-2018-16491
CWE
CWE-400
Snyk ID
SNYK-JS-NODEEXTEND-73641
Disclosed
30 Nov, 2018
Published
01 Feb, 2019