Remote Memory Exposure

Affecting node-addon-api package, versions >=0.0.0 <1.7.2 || >=2.0.0 <2.0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-addon-api is a This module contains header-only C++ wrapper classes which simplify the use of the C based N-API provided by Node.js when using C++. It provides a C++ object model and exception handling semantics with low overhead.

Affected versions of this package are vulnerable to Remote Memory Exposure via the napi_get_value_string_utf8, napi_get_value_string_latin1 and napi_get_value_string_utf16 functions.

Remediation

Upgrade node-addon-api to version 1.7.2, 2.0.1 or higher.

References

CVSS Score

5.6
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CWE
CWE-201
Snyk ID
SNYK-JS-NODEADDONAPI-571001
Disclosed
03 Jun, 2020
Published
03 Jun, 2020