Privilege Escalation

Affecting mongodb-js-metrics package, versions <6.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mongodb-js-metrics is a Shareable metric recording.

Affected versions of this package are vulnerable to Privilege Escalation. A malicious 3rd party with local access to the Windows machine can execute arbitrary software with the privileges of the user who is running MongoDB Compass.

Remediation

Upgrade mongodb-js-metrics to version 6.0.0 or higher.

References

CVSS Score

4.0
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2021-20334
CWE
CWE-264
Snyk ID
SNYK-JS-MONGODBJSMETRICS-1243685
Disclosed
07 Apr, 2021
Published
07 Apr, 2021