Insufficient Validation

Affecting electron package, versions <9.4.0 || >=10.0.0 <10.2.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Insufficient Validation in V8.

Remediation

Upgrade electron to version 9.4.0, 10.2.0 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:F
Credit
Unknown
CVE
CVE-2020-16040
CWE
CWE-20
Snyk ID
SNYK-JS-ELECTRON-1050882
Disclosed
13 Dec, 2020
Published
13 Dec, 2020