Uncontrolled Recursion

Affecting org.webjars.npm:node-sass artifact, versions [0,]

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

org.webjars.npm:node-sass is a Node.js bindings to libsass.

Affected versions of this package are vulnerable to Uncontrolled Recursion via Sass::Eval::operator()(Sass::Binary_Expression*) in eval.cpp. Note: node-sass is affected by this vulnerability due to its bundled usage of the libsass package.

Remediation

There is no fixed version for org.webjars.npm:node-sass.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Credit
Unknown
CVE
CVE-2019-18797
CWE
CWE-79
Snyk ID
SNYK-JAVA-ORGWEBJARSNPM-541163
Disclosed
11 Aug, 2019
Published
08 Jan, 2020