Cross-site Scripting (XSS)

Affecting org.opencms:opencms-core artifact, versions [,11.0.1)

Do your applications use this vulnerable package? Test your applications

Overview

org.opencms:opencms-core is a Java open source content management system by Alkacon Software.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the search engine.

Remediation

Upgrade org.opencms:opencms-core to version 11.0.1 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2019-13234
CWE
CWE-79
Snyk ID
SNYK-JAVA-ORGOPENCMS-536065
Disclosed
12 Nov, 2019
Published
26 Nov, 2019