Cross-site Request Forgery (CSRF)

Affecting org.infinispan:infinispan-server-rest artifact, versions [,12.0.0.CR1)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

org.infinispan:infinispan-server-rest is an Infinispan Rest Server.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). It is possible to perform various actions that could have side effects using GET requests. This flaw allows an attacker to perform a cross-site request forgery (CSRF) attack.

Remediation

Upgrade org.infinispan:infinispan-server-rest to version 12.0.0.CR1 or higher.

References

CVSS Score

7.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L
Credit
Unknown
CVE
CVE-2020-10771
CWE
CWE-352
Snyk ID
SNYK-JAVA-ORGINFINISPAN-1299901
Disclosed
03 Jun, 2021
Published
04 Jun, 2021