Improper Input Validation

Affecting org.apache.httpcomponents:httpclient artifact, versions [,4.5.13) || [5.0.0, 5.0.3)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

org.apache.httpcomponents:httpclient is a HttpClient component of the Apache HttpComponents project.

Affected versions of this package are vulnerable to Improper Input Validation. A malformed authority component in request URIs passed to the library as java.net.URI object will result in picking the wrong target host for request execution.

Remediation

Upgrade org.apache.httpcomponents:httpclient to version 4.5.13, 5.0.3 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2020-13956
CWE
CWE-20
Snyk ID
SNYK-JAVA-ORGAPACHEHTTPCOMPONENTS-1016906
Disclosed
08 Oct, 2020
Published
09 Oct, 2020