Insecure Default

Affecting org.apache.camel:camel-netty artifact, versions [2.22.0,2.25.1) || [3.0.0-M1,3.2.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

org.apache.camel:camel-netty is a Netty component for Apache Camel.

Affected versions of this package are vulnerable to Insecure Default. It enables Java deserialization by default.

Remediation

Upgrade org.apache.camel:camel-netty to version 2.25.1, 3.2.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Colm O. HEigeartaigh
CVE
CVE-2020-11973
CWE
CWE-453
Snyk ID
SNYK-JAVA-ORGAPACHECAMEL-569124
Disclosed
14 May, 2020
Published
14 May, 2020