Privilege Escalation

Affecting github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity package, versions >=3.1.0 <3.2.0

Do your applications use this vulnerable package? Test your applications

Overview

github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity is an open source container platform designed to be simple, fast, and secure.

Affected versions of this package are vulnerable to Privilege Escalation. An attacker with local or network access to the host system (e.g. ssh) may be allowed to edit files within /run/singularity/instances/sing/<user>/<instance>. This is due to insecure permissions handling.

Remediation

Upgrade github.com/sylabs/singularity/internal/pkg/runtime/engines/singularity to version 3.2.0 or higher.

References

CVSS Score

8.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L/RL:O
Credit
Unknown
CVE
CVE-2019-11328
CWE
CWE-269
Snyk ID
SNYK-GOLANG-GITHUBCOMSYLABSSINGULARITYINTERNALPKGRUNTIMEENGINESSINGULARITY-174726
Disclosed
14 May, 2019
Published
04 Jul, 2019