Insufficient Validation

Affecting opcfoundation.netstandard.opc.ua package, versions [,1.4.359.31)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

OPCFoundation.NetStandard.Opc.Ua is a package that contains the OPC UA reference implementation and is targeting the .NET Standard Library.

Affected versions of this package are vulnerable to Insufficient Validation. Encrypted user credentials sent to a misbehaving Server can be intercepted and reused by an attacker.

Remediation

Upgrade OPCFoundation.NetStandard.Opc.Ua to version 1.4.359.31 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:U/RL:O/RC:C
Credit
Bernd Edlinger
CVE
CVE-2019-19135
CWE
CWE-200
Snyk ID
SNYK-DOTNET-OPCFOUNDATIONNETSTANDARDOPCUA-560386
Disclosed
16 Mar, 2020
Published
16 Mar, 2020