Open Redirect

Affecting microsoft.aspnetcore.server.iis package, versions [2.2.0, 2.2.6)

Do your applications use this vulnerable package? Test your applications

Overview

microsoft.aspnetcore.server.iis is a that provides support for hosting ASP.NET Core in IIS using the AspNetCoreModule.

Affected versions of this package are vulnerable to Open Redirect. A spoofing vulnerability exists that could lead to an redirection. An attacker who successfully exploits this vulnerability could redirect a targeted user to a malicious website.

Remediation

Upgrade microsoft.aspnetcore.server.iis to version 2.2.6 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
Datalust
CVE
CVE-2019-1075
CWE
CWE-601
Snyk ID
SNYK-DOTNET-MICROSOFTASPNETCORESERVERIIS-451561
Disclosed
09 Jul, 2019
Published
10 Jul, 2019