Cross-site Scripting (XSS)

Affecting gitlab package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gitlab package.

An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.4. It was possible to exploit a stored cross-site-scripting in merge request via a specifically crafted branch name.

Remediation

There is no fixed version for Debian:unstable gitlab.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2021-22196
CWE
CWE-79
Snyk ID
SNYK-DEBIANUNSTABLE-GITLAB-1243845
Disclosed
02 Apr, 2021
Published
07 Apr, 2021