Improper Input Validation

Affecting subversion package, versions <1.8.8-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream subversion package. See Remediation section below for Debian:9 relevant versions.

The get_resource function in repos.c in the mod_dav_svn module in Apache Subversion before 1.7.15 and 1.8.x before 1.8.6, when SVNListParentPath is enabled, allows remote attackers to cause a denial of service (crash) via vectors related to the server root and request methods other than GET, as demonstrated by the "svn ls http://svn.example.com&#34; command.

Remediation

Upgrade Debian:9 subversion to version 1.8.8-1 or higher.

References

CVSS Score

4.3
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVE
CVE-2014-0032
CWE
CWE-20
Snyk ID
SNYK-DEBIAN9-SUBVERSION-344403
Disclosed
14 Feb, 2014
Published
14 Feb, 2014