Arbitrary Code Injection

Affecting ruby2.3 package, versions <2.3.3-1+deb9u6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2019-8324
CWE
CWE-94
Snyk ID
SNYK-DEBIAN9-RUBY23-341495
Disclosed
17 Jun, 2019
Published
27 Mar, 2019