Directory Traversal

Affecting ruby2.3 package, versions <2.3.3-1+deb9u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream ruby2.3 package. See Remediation section below for Debian:9 relevant versions.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

Remediation

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u3 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
CVE
CVE-2018-1000079
CWE
CWE-22
Snyk ID
SNYK-DEBIAN9-RUBY23-308572
Disclosed
13 Mar, 2018
Published
13 Mar, 2018