Security Features

Affecting ruby2.3 package, versions <2.3.3-1+deb9u4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream ruby2.3 package. See Remediation section below for Debian:9 relevant versions.

An issue was discovered in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. It does not taint strings that result from unpacking tainted strings with some formats.

Remediation

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u4 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2018-16396
Snyk ID
SNYK-DEBIAN9-RUBY23-308543
Disclosed
16 Nov, 2018
Published
19 Oct, 2018