Out-of-Bounds

Affecting postgresql-9.6 package, versions <9.6.22-0+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-9.6 package. See Remediation section below for Debian:9 relevant versions.

A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:9 postgresql-9.6 to version 9.6.22-0+deb9u1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2021-32027
CWE
CWE-119 CWE-190
Snyk ID
SNYK-DEBIAN9-POSTGRESQL96-1292196
Disclosed
01 Jun, 2021
Published
13 May, 2021