Versions mentioned in the description apply to the upstream
Remediation section below for
Debian:9 relevant versions.
A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
postgresql-9.6 to version 9.6.22-0+deb9u1 or higher.