OS Command Injection

Affecting patch package, versions <2.7.5-1+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

GNU patch through 2.7.6 is vulnerable to OS shell command injection that can be exploited by opening a crafted patch file that contains an ed style diff payload with shell metacharacters. The ed editor does not need to be present on the vulnerable system. This is different from CVE-2018-1000156.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2019-13638
CWE
CWE-78
Snyk ID
SNYK-DEBIAN9-PATCH-453538
Disclosed
26 Jul, 2019
Published
24 Jul, 2019