Out-of-bounds Read

Affecting libxml2 package, versions <2.9.4+dfsg1-2.2+deb9u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. GNOME project libxml2 v2.9.10 has a global buffer over-read vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c. The issue has been fixed in commit 50f06b3e.

Remediation

Upgrade libxml2 to version or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
CVE
CVE-2020-24977
CWE
CWE-125
Snyk ID
SNYK-DEBIAN9-LIBXML2-609786
Disclosed
04 Sep, 2020
Published
05 Sep, 2020