Use After Free

Affecting libxml2 package, versions <2.9.4+dfsg1-2.2+deb9u4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:9 relevant versions.

There's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:9 libxml2 to version 2.9.4+dfsg1-2.2+deb9u4 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2021-3516
CWE
CWE-416
Snyk ID
SNYK-DEBIAN9-LIBXML2-1277344
Disclosed
01 Jun, 2021
Published
28 Apr, 2021