Out-of-bounds Write

Affecting libsndfile package, versions <1.0.27-3+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libsndfile package. See Remediation section below for Debian:9 relevant versions.

A heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file.

Remediation

Upgrade Debian:9 libsndfile to version 1.0.27-3+deb9u2 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2021-3246
CWE
CWE-787
Snyk ID
SNYK-DEBIAN9-LIBSNDFILE-1325344
Disclosed
20 Jul, 2021
Published
23 Jul, 2021