Source Code

Affecting krb5 package, versions <1.13.2+dfsg-3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package. See Remediation section below for Debian:9 relevant versions.

lib/gssapi/krb5/iakerb.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted IAKERB packet that is mishandled during a gss_inquire_context call.

Remediation

Upgrade Debian:9 krb5 to version 1.13.2+dfsg-3 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2015-2696
CWE
CWE-18
Snyk ID
SNYK-DEBIAN9-KRB5-395748
Disclosed
09 Nov, 2015
Published
09 Nov, 2015