Cross-site Scripting (XSS)

Affecting jquery package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2020-11022
CWE
CWE-79
Snyk ID
SNYK-DEBIAN9-JQUERY-567908
Disclosed
29 Apr, 2020
Published
30 Apr, 2020