Excessive Iteration

Affecting imagemagick package, versions <8:6.9.7.4+dfsg-11+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ImageMagick 7.0.6-1 has a large loop vulnerability in the ReadPWPImage function in coders\pwp.c.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2017-12587
CWE
CWE-834
Snyk ID
SNYK-DEBIAN9-IMAGEMAGICK-402480
Disclosed
06 Aug, 2017
Published
06 Aug, 2017