Buffer Overflow

Affecting graphviz package, versions <2.38.0-17+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream graphviz package. See Remediation section below for Debian:9 relevant versions.

Buffer Overflow in Graphviz Graph Visualization Tools from commit ID f8b9e035 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by loading a crafted file into the "lib/common/shapes.c" component.

Remediation

Upgrade Debian:9 graphviz to version 2.38.0-17+deb9u1 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2020-18032
CWE
CWE-120
Snyk ID
SNYK-DEBIAN9-GRAPHVIZ-1279005
Disclosed
29 Apr, 2021
Published
04 May, 2021